summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 36 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a930e7101fe0..9209bf002310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,44 @@
-#Maintainer: Eli Patterson <elipup@gmail.com>
-#Contributer: Franz Müller <ethylisocyanat@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributer: Eli Patterson <elipup@gmail.com>
+# Contributer: Franz Müller <ethylisocyanat@gmail.com>
-pkgname=('python-osmnx')
-_pyname=osmnx
-pkgver=0.9
+_pkgname='osmnx'
+pkgname="python-${_pkgname}"
+pkgver=0.16.0
pkgrel=1
-pkgdesc='Python framework for osm street network visualization'
-url='https://github.com/gboeing/osmnx'
+pkgdesc='Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data'
arch=('any')
+url='https://github.com/gboeing/osmnx'
license=('MIT')
-depends=('python-requests>=2.21' 'python-numpy>=1.15' 'python-pandas>=0.23' 'python-geopandas>=0.4' 'python-networkx>=2.2' 'python-matplotlib>=2.2' 'python-shapely>=1.6' 'python-descartes>=1.1' 'python-geopy>=1.14' 'python-rtree>=0.8.3')
+depends=('python'
+ 'python-descartes'
+ 'python-folium'
+ 'python-geopandas'
+ 'python-matplotlib'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-pyproj'
+ 'python-requests'
+ 'python-rtree'
+ 'python-scikit-learn'
+ 'python-scipy'
+ 'python-shapely')
makedepends=('python-setuptools')
-source=("https://github.com/gboeing/osmnx/archive/v$pkgver.tar.gz")
-sha256sums=('0653e839e84f557ee6bff29e50e17e704aa7c35f800c7b58f8c84317205049dc')
+provides=("${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('394a777cdf4314fdd63735184b4de3f53515e9ba79cc7d1252ca49d870808858')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
package() {
- cd "$srcdir/$_pyname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
-} \ No newline at end of file
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
+ install -Dm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: