summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a087a4b895c4..80f3732cd3b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,24 @@
pkgname=python-overpy
pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Python Wrapper to access the Overpass API"
arch=(any)
url="https://github.com/DinoTools/python-overpy"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools' 'git' 'python-pytest-runner')
source=(git+https://github.com/DinoTools/python-overpy.git#tag=$pkgver)
sha256sums=('SKIP')
+buid() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
package() {
cd "$srcdir/$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1
-
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}