summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16902389655f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ebiadsu <ebiadsu@posteo.de>
+_pipname=ovh
+pkgname=python-${_pipname}
+pkgver=0.4.7
+pkgrel=1
+pkgdesc="Official OVH.com API wrapper"
+arch=("x86_64")
+url="https://api.ovh.com"
+license=('custom')
+makedepends=("python" "python-pip")
+
+prepare() {
+ # manual download to get LICENSE file
+ pip download ${_pipname}
+ cd $srcdir
+ tar -xvzf ${_pipname}-$pkgver.tar.gz ${_pipname}-$pkgver/LICENSE
+}
+
+build() {
+ pip install --no-deps --target="${_pipname}" ${_pipname}
+}
+
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.6/site-packages/
+ cp -r $srcdir/${_pipname}/* $pkgdir/usr/lib/python3.6/site-packages/
+
+ # install license file
+ install -Dm644 ${_pipname}-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}