summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98149606f2e9..7ff76417d4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,27 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# PKGBUILD generated by pipman
# Python package author: Sergio Correia <sergio.correia@gmail.com>
-pkgname=python-panflute
+
+_pipname=panflute
+pkgname=python-$_pipname
pkgver=1.11.2
pkgrel=1
pkgdesc="Pythonic Pandoc filters"
arch=(any)
-url="https://github.com/sergiocorreia/panflute"
+url="https://github.com/sergiocorreia/$_pipname"
license=(BSD3)
makedepends=("python" "python-pip")
+depends=("python-click"
+ "python-future"
+ "python-pyyaml"
+ "python-shutilwhich")
+
build() {
- pip install --no-deps --target="panflute" panflute==1.11.2
+ pip install --no-deps --target="$_pipname" "$_pipname==$pkgver"
}
+
package() {
sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- mkdir -p $pkgdir/"$sitepackages"
- cp -r $srcdir/panflute/* $pkgdir/"$sitepackages"
-} \ No newline at end of file
+ mkdir -p "$pkgdir/$sitepackages"
+ cp -r "$srcdir/$_pipname"/* "$pkgdir/$sitepackages"
+}