summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a6679c2d0dd..fa541d6b29c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-parfive
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2.0.2
+pkgver=2.1.0
pkgrel=1
pkgdesc="A HTTP and FTP parallel file downloader"
arch=('any')
@@ -25,15 +25,14 @@ checkdepends=('python-pytest-socket'
'python-aioftp'
'python-aiofiles') #python-aiohttp tqdm
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('87a9048a02e1c1386d1c092fb9f646f8')
+md5sums=('3eea9c15a18d9837d62320d013a7ab28')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python -m build --wheel --no-isolation
msg "Building Docs"
- cd ${srcdir}/${_pyname}-${pkgver}/docs
- PYTHONPATH="../build/lib" make html
+ PYTHONPATH="../build/lib" make -C docs html
}
check() {
@@ -41,11 +40,11 @@ check() {
# deselect tests that may take long time
pytest \
- --deselect=parfive/tests/test_downloader.py::test_ftp || warning "Tests failed" # -vv --color=yes
+ --deselect=parfive/tests/test_downloader.py::test_ftp || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-parfive() {
- depends=('python>=3.7' 'python-tqdm>=4.27.0' 'python-aiohttp' 'python-typing_extensions')
+ depends=('python>=3.8' 'python-tqdm>=4.27.0' 'python-aiohttp')
optdepends=('python-aioftp>=0.17.1: For downloads over FTP'
'python-parfive-doc: Documentation for Parfive')
cd ${srcdir}/${_pyname}-${pkgver}