summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9313f8feb46..4c2e37cfd551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
_base=pathos
pkgname=python-${_base}
pkgdesc="parallel graph management and execution in heterogeneous computing"
-pkgver=0.2.8
-pkgrel=3
+pkgver=0.2.9
+pkgrel=1
url="https://github.com/uqfoundation/${_base}"
arch=(any)
license=('custom:BSD-3-clause')
depends=(python-dill python-ppft python-pox python-multiprocess)
makedepends=(python-setuptools)
source=(${url}/archive/${_base}-${pkgver}.tar.gz)
-sha512sums=('3552e7db41ec134fdebcda0e8e483e1f06e8de18b1e31184599d44c35367baf02f04d8c4f8932820e1793eeb81c4fddab6eb2026fae0ebd932be50d708f2e214')
+sha512sums=('56469bf955bc095a8f9b501110d03c09c1e16f7317626fe506269c607c006be1c6e93c9221b4af7144e0bc277dd1d68487b648d216de919f24d3c1d9fe21f0fb')
build() {
- cd "${_base}-${_base}-${pkgver}"
+ cd ${_base}-${_base}-${pkgver}
python setup.py build
}
package() {
- cd "${_base}-${_base}-${pkgver}"
+ cd ${_base}-${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}