summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bb0a29dd7b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-pcloudapi-git
+pkgver=v0.0.2.r0.gc303afe
+pkgrel=1
+pkgdesc="A python3 library for accessing the pcloud.com API"
+arch=("any")
+url="https://github.com/tochev/python3-pcloudapi"
+license=("MIT")
+depends=("python" "python-requests")
+options=("!emptydirs")
+source=("git+https://github.com/tochev/python3-pcloudapi")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "python3-pcloudapi"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/python3-pcloudapi"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -m 644 -D LICENCE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}