summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4802c3024617..85b2a00610c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Kherim Willems <aur@kher.im>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=python-pdb2pqr
_name=${pkgname#python-}
-pkgver=3.1.0
+pkgver=3.6.2
pkgrel=1
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
-depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
+depends=('python>=3.5' 'python-mmcif-pdbx>=1.1.2' python-numpy
+ 'python-propka>=3.5' python-requests python-docutils)
+checkdepends=('python-pandas>=1.0' python-pytest python-testfixtures)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820')
+sha256sums=('SKIP')
options=(!emptydirs)
build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ python setup.py build
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}