summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e06b729b99dd..237145672d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,24 @@
pkgname=python-pdb2pqr
_name=${pkgname#python-}
pkgver=3.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0')
+makedepends=(patch)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "fix_entrypoint.patch")
+sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0'
+ 'bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211')
options=(!emptydirs)
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ patch -Np0 -i "${srcdir}/fix_entrypoint.patch"
+}
+
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build