summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97b8d6e1f1f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: brokenpip3 <brokenpip3[at]gmail[dot]com>
+
+pkgname=python-pdpyras
+pkgver=4.3.0
+_name=pdpyras
+pkgrel=1
+pkgdesc="Low-level PagerDuty REST API Client in Python"
+arch=('any')
+url="https://github.com/PagerDuty/pdpyras"
+license=('MIT')
+depends=('python-requests')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('dd5f010f40b85282d8aabbd6b7aaee4018651667539f45b9055619ac40a5aefe')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}