summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 22 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61ecf23a57f2..1a4ee8f9d31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,34 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-
-pkgname=python-persim
-_pkg=persim
-pkgver=0.3.1
+_base=persim
+pkgname=python-${_base}
+pkgver=0.3.2
pkgrel=1
pkgdesc="Distances and representations of persistence diagrams"
-arch=('any')
-url="https://github.com/scikit-tda/persim"
-license=('MIT')
-depends=(
- 'python-deprecated'
- 'python-hopcroftkarp'
- 'python-joblib'
- 'python-matplotlib'
- 'python-numpy'
- 'python-scipy'
- 'python-scikit-learn')
-makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
-checkdepends=('python-pytest')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('ef0f0a247adcf6104ecac14117db0b24581710ea8a8d964816805395700b4975')
+arch=(any)
+url="https://github.com/scikit-tda/${_base}"
+license=(MIT)
+depends=(python-scikit-learn python-matplotlib python-hopcroftkarp python-deprecated)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('bd9c5ae69834f3931f4d8886da14770786396a28710b5565deb085d47642c8a383bfd49e4cec91bcd22a4c2f7727279ab7f7598b5ee971716278596be52ed484')
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "$_pkg-$pkgver"
- PYTHONPATH="$PWD" pytest -x --disable-warnings
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/$_pkg-$pkgver.dist-info/LICENSE.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}