summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64cfbe9f5324..e97e9c5b8eb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Gergely Meszaros <maetveis at gmail dot com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Payson Wallach <payson@paysonwallach.com>
+# Contribute at https://gitlab.com/Maetveis/aur-packages
+
pkgname=python-persist-queue
_pkg="${pkgname#python-}"
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc='Thread-safe disk-based persistent queue'
arch=('any')
url="https://github.com/peter-wangxu/persist-queue"
license=('BSD')
depends=('python')
-optdepends=('python-msgpack' 'python-pymysql' 'python-dbutils')
+optdepends=('python-msgpack: MessagePack serialization support'
+ 'python-cbor2: CBOR serialization support')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
# checkdepends=(
# 'python-dbutils'
@@ -20,7 +24,7 @@ makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel
# 'python-mock'
# 'python-pymysql')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('a236c9fe2a14c16a3fc37452ccd12d7ad807468199f51e942f4fdc29f495a2fc')
+sha256sums=('09bb473f0c0a3a333ef5225f19f638c58f912a3e947cba3317451f137e8a8143')
prepare() {
cd "$_pkg-$pkgver"