summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..add1a2b63078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: jmcb <joelsgp@protonmail.com>
+
+pkgname=python-picotool-git
+_name=picotool
+pkgver=0.1
+pkgrel=1
+pkgdesc="Tools and Python libraries for manipulating Pico-8 game files. "
+arch=('any')
+url="https://github.com/dansanderson/picotool"
+license=('MIT')
+depends=('python' 'python-pypng')
+makedepends=('git' 'python-pytest-runner')
+checkdepends=('flake8' 'mypy' 'python-pytest')
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/dansanderson/picotool.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$_name"
+ python setup.py build
+}
+
+# check() {
+# cd "$_name"
+# pytest
+# }
+
+package() {
+ cd "$_name"
+ python setup.py install --root="$pkgdir" --optimize=1
+}