summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b4945020cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+pkgname=python-pkgbuild-git
+pkgver=r3.aeca84e
+pkgrel=1
+pkgdesc="Python library to parse pacman's .SRCINFO file"
+arch=('any')
+url="https://github.com/z3ntu/python-pkgbuild"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+source=(git+https://github.com/z3ntu/python-pkgbuild)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/python-pkgbuild"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/python-pkgbuild"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+