summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acc130b3c559..086dfefd4412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-_pipname=plum
-pkgname=python-${_pipname,,}
-pkgver=0.7.2
+_pyname=plum
+pkgname=python-${_pyname,,}
+pkgver=0.8.7
pkgrel=1
pkgdesc='Pack/Unpack Memory'
arch=(any)
-url="https://$_pipname-py.readthedocs.io/en/latest/"
+url="https://$_pyname-py.readthedocs.io/en/latest/"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
-_archive="$_pipname-$pkgver"
-source=("https://gitlab.com/dangass/$_pipname/-/archive/$pkgver/$_archive.tar.bz2")
-sha256sums=('6b2863af4db754892d690563b8304b43c246e8d3a1124ad8aeab83f2fc86ffbc')
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
+_archive="$_pyname-$pkgver"
+source=("https://gitlab.com/dangass/$_pyname/-/archive/$pkgver/$_archive.tar.bz2")
+sha256sums=('d0e0a40ac106260ce820018e22ef0cdcc569b267de51e667585b87f4215c2cd8')
+
+prepare() {
+ cd "$_archive"
+ sed -i -e '/python_requires/d' setup.cfg
+}
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}