summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18ef6040a80c..eaca9dae37b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
_pipname=plum
pkgname=python-${_pipname,,}
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Pack/Unpack Memory'
arch=(any)
url="https://$_pipname-py.readthedocs.io/en/latest/"
license=(MIT)
depends=(python)
makedepends=(python-setuptools)
-source=("https://gitlab.com/dangass/$_pipname/-/archive/$pkgver/$_pipname-$pkgver.tar.bz2")
+_archive="$_pipname-$pkgver"
+source=("https://gitlab.com/dangass/$_pipname/-/archive/$pkgver/$_archive.tar.bz2")
sha256sums=('ad3302aaddd76dba09a96c4006db1c899937c6c5b3ffbf495b69b1bb3bcc7701')
build() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}