summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd8a400bc195..eb292a902793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-poliastro
_pyname=${pkgname#python-}
-pkgver=0.11.1
+pkgver=0.12.0
pkgrel=1
pkgdesc="Astrodynamics and Orbital Mechanics computations"
arch=('i686' 'x86_64')
@@ -17,10 +17,9 @@ checkdepends=('python-pytest'
'python-astroquery'
'python-plotly'
'python-jplephem'
-# 'python-soupsieve'
'python-numba')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('365466f0072800998cbbd44cc724c696')
+md5sums=('92ceb28714723ae63381d8a241b9aad9')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -35,9 +34,11 @@ check() {
}
package() {
- depends=('python>=3.5' 'python-astropy' 'python-jplephem' 'python-matplotlib')
+ depends=('python>=3.5' 'python-astropy' 'python-jplephem' 'python-matplotlib' 'python-plotly' 'python-retrying')
optdepends=('python-numba: For accelerating the code'
'python-poliastro-doc: Documentation for poliastro'
+ 'python-pandas'
+ 'python-astroquery'
'python-pytest: For running the tests from the package')
cd ${srcdir}/${_pyname}-${pkgver}