summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 138c1c748ed4..a364ca0eaf8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-pptx
_pypiname=${pkgname}
-pkgver=0.6.19
+pkgver=0.6.21
pkgrel=1
pkgdesc="Create Open XML PowerPoint documents in Python"
url="https://github.com/scanny/python-pptx"
@@ -10,11 +10,16 @@ arch=('any')
license=('MIT')
depends=('python' 'python-behave' 'flake8' 'python-lxml' 'python-mock'
'python-pyparsing' 'python-pillow' 'python-pytest' 'python-xlsxwriter')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/scanny/python-pptx/archive/v${pkgver}.tar.gz")
-sha256sums=('116b24237ecb12a831699fd784dbac947b8bee6c27f99262a0207f6fccb7c9e4')
+sha256sums=('200978486240c98d8c63c903f0a7ce7ff030045e31e8c4519cd6317bfaa2e66f')
+
+build() {
+ cd "${_pypiname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd ${_pypiname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pypiname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}