summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52b836aebec4..5aa3f92655f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,25 @@
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=python-prospector
-pkgver=0.12
+pkgver=0.12.7
pkgrel=1
pkgdesc="Python static analysis tool"
arch=('any')
-makedepends=('python-setuptools' 'pydocstyle' 'python-pep8-naming' 'python-yaml' 'python-dodgy' 'python-setoptconf'
- 'python-requirements-detector' 'python-pylint-common' 'python-pylint-plugin-utils'
- 'python-pylint-django' 'python-pylint-celery' 'python-pylint-flask')
+makedepends=('python-setuptools'
+ 'pydocstyle'
+ 'python-pep8-naming'
+ 'python-mccabe'
+ 'python-pycodestyle'
+ 'python-pyflakes'
+ 'python-yaml'
+ 'python-dodgy'
+ 'python-setoptconf'
+ 'python-requirements-detector'
+ 'python-pylint-common'
+ 'python-pylint-plugin-utils'
+ 'python-pylint-django'
+ 'python-pylint-celery'
+ 'python-pylint-flask')
optdeps=('python-pyroma: check setup.py'
'python-vulture: find dead code')
url="https://github.com/landscapeio/prospector"
@@ -17,14 +29,12 @@ md5sums=('45d00e6b6b70b69d3f02c64c74f9f40c')
build() {
cd "$srcdir/${pkgname#python-}-$pkgver"
-
python setup.py build
}
package() {
cd "$srcdir/${pkgname#python-}-$pkgver"
-
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}
# vim:set ts=2 sw=2 et: