summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c05973c360a7..44eabd4c7e24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
_name=PubChemPy
pkgname=python-pubchempy
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc='A simple Python wrapper around the PubChem PUG REST API.'
arch=(any)
url="https://github.com/mcs07/$_name"
license=(MIT)
depends=(python python-alembic python-sqlalchemy)
optdepends=(python-pandas)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
sha256sums=('24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e')
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/${_name//-/_}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}