summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3901ae0b66c9..1b920a05b6f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,16 @@ replaces=("python-pulsar")
source=("python-pulsar-git::git+https://github.com/quantmind/pulsar.git")
md5sums=("SKIP")
-pkgver() {
- cd "$pkgname"
- cat pulsar.egg-info/PKG-INFO |grep "^Version:" | awk '{print $2}'
-}
build() {
+ true
+}
+
+pkgver() {
cd "$pkgname"
- python setup.py build
+ # Build needs to be done here to get right version
+ python setup.py build >/dev/stderr
+ cat pulsar.egg-info/PKG-INFO |grep "^Version:" | awk '{print $2}'
}
package() {