summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 287452ec9d01..607b37b3c357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pyelastix
pkgname=python-$_pkgname
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python wrapper for the Elastix nonrigid registration toolkit"
arch=('x86_64')
url="https://github.com/almarklein/pyelastix"
@@ -14,6 +14,10 @@ sha512sums=('e3258111ece1ad67f9de8469200ee06a3d8db4d07b85a6ba0fa96c41ba6e3744531
package() {
cd "$srcdir/$_pkgname-$pkgver"
+
+ # do not run Python subprocess through the shell
+ sed -i '304s/True/False/' pyelastix.py
+
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --optimize=1 --root="$pkgdir"
}