summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 108038a2a131..334ed4dcd4cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,29 @@
pkgname=python-pyepsg
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='A simple interface to https://epsg.io/'
-url='https://github.com/rhattersley/pyepsg'
+url='https://pyepsg.readthedocs.io/'
arch=('any')
license=('LGPL3')
+
depends=('python-requests')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+_pypi=pyepsg
source=(
- "https://files.pythonhosted.org/packages/source/p/pyepsg/pyepsg-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
'2d08fad1e7a8b47a90a4e43da485ba95705923425aefc4e2a3efa540dbd470d7'
)
build() {
- cd "pyepsg-$pkgver"
- python setup.py build
+ cd "$_pypi-$pkgver"
+ python -m build --no-isolation --wheel
}
package() {
- cd "pyepsg-$pkgver"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ cd "$_pypi-$pkgver"
+ python -m installer --destdir="$pkgdir" "dist/$_pypi-$pkgver-"*.whl
}