summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6ff2d83bd14..ed854b4679ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,15 @@ url="http://www.pyfmi.org"
arch=('i686' 'x86_64')
license=('LGPL')
makedepends=('python-setuptools' 'python2-setuptools' 'fmilib' 'cython' 'cython2' 'python-assimulo' 'python2-assimulo' 'python-lxml' 'python2-lxml')
-source=("https://pypi.io/packages/source/P/PyFMI/PyFMI-${pkgver}.tar.gz")
-sha256sums=('f0485f786a40448c8ffb9e2b03a587d84cd1fe403c1056f50ab787de18f8ba0b')
+source=("https://pypi.io/packages/source/P/PyFMI/PyFMI-${pkgver}.tar.gz" unzip_dir_encoding_fix.patch)
+sha256sums=('f0485f786a40448c8ffb9e2b03a587d84cd1fe403c1056f50ab787de18f8ba0b' SKIP)
prepare() {
- rm "${srcdir}"/PyFMI-${pkgver}/src/pyfmi/*.c
+ cd "${srcdir}"/PyFMI-${pkgver}
+ rm src/pyfmi/*.c
+
+ # bug in https://github.com/modelon/PyFMI/commit/decbb8340620c13c08e2acb5c4ae52ee2008462c
+ patch -p1 -i "${srcdir}"/unzip_dir_encoding_fix.patch
}
build() {