summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8a19de347a3..485797df9eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Charles Vejnar
+# Maintainer: Charles Vejnar <first name [dot] last name [at] gmail [dot] com>
pkgname=python-pyfnutils
pkgver=1.3
@@ -8,22 +8,16 @@ arch=("any")
url="https://github.com/vejnar/pyfnutils"
license=("MPLv2")
depends=("python")
-makedepends=("python-setuptools" "python-pip" "python-wheel")
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
source=("https://github.com/vejnar/pyfnutils/archive/refs/tags/v$pkgver.tar.gz")
sha1sums=("055825e6dbeebde50e955535c22a7af973ea4d41")
+build() {
+ cd "$srcdir/pyfnutils-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "$srcdir/pyfnutils-$pkgver"
- pip install --disable-pip-version-check \
- --ignore-installed \
- --isolated \
- --no-deps \
- --no-build-isolation \
- --no-index \
- --no-cache-dir \
- --no-warn-script-location \
- --root="$pkgdir" \
- .
- cd "${pkgdir}"
- python -O -m compileall "usr/lib"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}