summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f012d333c824..070b97bb0d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,21 @@ _pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
pkgver=0.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6>=6.1.1')
-makedepends=('python-pip' 'cython' 'python-setuptools'
- 'gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
- 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
- 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
- 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
- 'python-nbsphinx' 'python-numpydoc' 'python-docformatter'
- 'python-black' 'python-blackdoc' 'dvc' 'python-isort'
- 'python-myst-parser' 'python-sphinx-copybutton' )
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.1.1')
+makedepends=('python-pip' 'cython' 'python-setuptools')
+ #'gmt-coast' 'gmt-dcw'
+ #'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+ #'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+ #'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+ #'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+ #'python-nbsphinx' 'python-numpydoc' 'python-docformatter'
+ #'python-black' 'python-blackdoc' 'dvc' 'python-isort'
+ #'python-myst-parser' 'python-sphinx-copybutton' )
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
sha256sums=('65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8')
@@ -27,15 +28,15 @@ build() {
USE_NCCONFIG=1 python setup.py build
}
-check() {
-# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
-# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
-# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
-# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
-# 'python-nbsphinx' 'python-numpydoc')
- cd ${_pkg}-${pkgver}
- PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()' || return 0
-}
+#check() {
+## depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+## 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+## 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+## 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+## 'python-nbsphinx' 'python-numpydoc')
+# cd ${_pkg}-${pkgver}
+# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()' || true
+#}
package() {
cd ${_pkg}-${pkgver}