summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfe284616394..faf6e2249445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ _pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
pkgver=0.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt')
-makedepends=('python-pip' 'cython' 'python-setuptools')
+makedepends=('python-pip' 'cython' 'python-setuptools' 'python-setuptools-scm')
#'gmt-coast' 'gmt-dcw'
#'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
#'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
@@ -25,7 +25,8 @@ sha256sums=('95346786a0a51c03bec1d6ace81a6c5ce98706cc9ffb05c7d77b966a5b85ff79')
build() {
cd ${_pkg}-${pkgver}
- USE_NCCONFIG=1 python setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ python -m build -nw
}
#check() {
@@ -40,5 +41,6 @@ build() {
package() {
cd ${_pkg}-${pkgver}
- USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}