summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8756354932e1..6701b7f4e840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,19 @@ pkgbase=python-${_pkg,,}
pkgname=("python-${_pkg,,}")
pkghashver=997b88c855c12ffacd2c4b911f3fa83244ce8d7b
pkgver=0.0.1a0_${pkghashver}
-pkgrel=3
+pkgrel=4
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6' 'gmt-coast' 'gmt-dcw')
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6')
makedepends=('cython' 'python-setuptools')
+optdepends=('gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+ 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+ 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+ 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+ 'python-nbsphinx' 'python-numpydoc')
+
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/${pkghashver}.tar.gz")
sha256sums=('990145de2d61df5d02f784e406a217138ee029f559454bcf7eb12a28f6258a60')
@@ -21,10 +27,10 @@ build() {
}
#check() {
-# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
-# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
# 'python-nbsphinx' 'python-numpydoc')
# cd ${_pkg}-${pkghashver}
# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'