summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14eee2295364..56eebd0393d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,29 @@
_pyname=pygtrie
pkgname=python-$_pyname
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python library implementing a trie data structure'
arch=(any)
url="https://github.com/google/$_pyname"
license=(Apache)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pyname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
sha256sums=('203514ad826eb403dab1d2e2ddd034e0d1534bbe4dbe0213bb0593f66beba4e2')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
check() {
cd "$_archive"
- python test.py
+ python -m unittest discover
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}