summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a5754f739e5..bf2405859c6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Vinicius Correa <vinicius dot correa at zoho dot com>
+
_pkgname=PyKCS11
pkgname=python-pykcs11
-pkgver=1.4.4
+pkgver=1.5.11
pkgrel=1
pkgdesc="PKCS#11 wrapper for Python."
-arch=('any')
-url="https://github.com/LudovicRousseau/${_pkgname}"
+arch=('x86_64')
+url="https://github.com/LudovicRousseau/pykcs11"
license=('GPL')
-depends=('python' 'swig')
-makedepends=('git')
-optdepends=()
-conflicts=()
-source=("https://github.com/LudovicRousseau/${_pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('dc5fdeeb92eeee7125eb418a523c59f8')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'swig')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('ef1d51a24eff9eb6c1288428996614316841e34bac2d59f483db0ed1a9cad044')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
}