summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5f4796e1164..afb57afc6c8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-_pkgname=pylint-django
+# Maintainer: Razer <razer@neuf.fr>
pkgname=python-pylint-django
-pkgver=0.7.2
+_pypi_pkgname=pylint-django
+pkgver=0.9.0
pkgrel=1
pkgdesc="Pylint plugin for improving code analysis for when using Django"
arch=('any')
url="https://github.com/landscapeio/pylint-django"
license=('GPL2')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-pylint-plugin-utils')
# source=(https://github.com/landscapeio/pylint-django/archive/${pkgver}.tar.gz)
# Temp source override because there's not tag for 0.7.2
-source=(https://github.com/landscapeio/pylint-django/archive/e381721eedcaf240bf56b038878c1e7fad848183.tar.gz)
-md5sums=('2106197486ad595e192242221493df7f')
+source=(https://files.pythonhosted.org/packages/source/p/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz)
+md5sums=('3a85d37a1cd56cabc518c2d0673bb83f')
build() {
- cd "${_pkgname}-"*
-
+ cd "${_pypi_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${_pkgname}-"*
-
+ cd "${_pypi_pkgname}-${pkgver}"
python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}