summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c167824eb8eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+key_bucket_filename="key.p")me=python-pymc3-git
+pkgver=v3.0beta.r653.g935779a
+pkgrel=1
+pkgdesc="Probabilistic Programming in Python. Uses Theano as a backend, supports NUTS and ADVI."
+arch=('any')
+url="http://pymc-devs.github.io/pymc3/"
+license=('APACHE')
+depends=('python-joblib' 'python-scipy' 'python-numpy' 'python-matplotlib' 'python-theano' 'python-pandas')
+conflicts=('python-pymc3')
+makedepends=('git' 'python-setuptools')
+options=(!emptydirs)
+source=("git+https://github.com/pymc-devs/pymc3.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pymc3"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/pymc3"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}