summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10e5f65f7f32..83f65584feae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: a821
pkgname=python-pynndescent
pkgver=0.5.8
-pkgrel=1
+pkgrel=2
pkgdesc="Simple fast approximate nearest neighbor search"
arch=('any')
url="https://github.com/lmcinnes/pynndescent"
@@ -9,8 +9,15 @@ license=('BSD')
depends=('python-joblib' 'python-numba' 'python-scikit-learn' 'python-scipy')
makedepends=('python-setuptools')
checkdepends=('python-pytest')
-source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz")
-sha256sums=('a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b')
+source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz"
+ "asarray.patch")
+sha256sums=('a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b'
+ '240c9413befb3f7dd58a0f02a32e58a07c54abeef70cdaa222a3ec7bd8da7d63')
+
+prepare() {
+ cd "pynndescent-$pkgver"
+ patch -p1 < ../asarray.patch
+}
check() {
cd "pynndescent-$pkgver"