summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 824e59f52ec6..96d7dd0e9084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=PyPardiso
pkgname=python-${_base,,}
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations"
arch=(any)
url="https://github.com/haasad/${_base}Project"
license=('custom:BSD-3-clause')
depends=(intel-oneapi-mkl python-scipy)
-makedepends=(python-build python-installer python-setuptools python-wheel)
+makedepends=(python-build python-installer python-setuptools-scm python-wheel)
checkdepends=(python-pytest)
source=(${_base}Project-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('4ced5d056f707ab282e77550fb1d36d68eb80a090e8cf2e8f5ce37797dcbd31460ead1a17e86ae42e7922d1741d01437b7482fc31c2f9c5a3240767a57d9e263')
+sha512sums=('0ccabdeda5357c555473b35eb5245f445d3feec13b8647556a5ff08fc19c5f8c4d6bafc14af89f9b6bb080040c7b5217d107dd7f0b4ea33ae25ceef62ababefa')
build() {
cd ${_base}Project-${pkgver}
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}