summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86ed159354a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=pypi2pkgbuild
+pkgname=python-$_pkgname-git
+pkgver=0.1.r26.g2c0e9c5
+pkgrel=1
+pkgdesc="Convert PyPI packages to Arch Linux packages"
+arch=('any')
+url="https://github.com/anntzer/pypi2pkgbuild"
+license=('MIT')
+depends=('python-pip' 'namcap' 'pkgfile')
+makedepends=('python-setuptools' 'git')
+conflicts=('python-pypi2pkgbuild')
+source=("git+https://github.com/anntzer/pypi2pkgbuild.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | \
+ sed 's/^v//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
+}