summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7eb94bcd688f..ed960302393d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@ _base=pyprecice
pkgname=python-${_base}
pkgdesc="Python language bindings for the preCICE coupling library"
pkgver=2.4.0.0
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://github.com/${_base/py/}/python-bindings"
license=(LGPL3)
depends=(precice python-mpi4py)
makedepends=(python-setuptools cython)
+checkdepends=(openssh)
source=(python-bindings-${pkgver}::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('c4001e676e623d299f9be214b1f04d95497e93fed1d68a1bf3ac1d12cd154fc6c6186c7918ebb7e5ebb73de57f783e9d9509a5b23ad42e8562aecec2925d413c')
@@ -24,6 +25,9 @@ build() {
}
check() {
+ if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ fi
cd python-bindings-"${pkgver}"
# https://github.com/precice/python-bindings/issues/1
python setup.py test