summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1d9bd18c2e4..475b381119ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,26 @@
pkgname=python-pypsrp
_pkgname=pypsrp
-pkgver=0.5.0
-pkgrel=1
+pkgver=0.8.1
+pkgrel=2
pkgdesc="Python PowerShell Remoting Protocol Client Library"
url="https://pypi.org/project/pypsrp/"
arch=('any')
license=('MIT')
-depends=('python' 'python-six' 'python-cryptography' 'python-requests' 'python-ntlm-auth')
-makedepends=('python-setuptools')
+depends=('python' 'python-six' 'python-cryptography' 'python-requests'
+ 'python-pyspnego' 'python-gssapi')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+optdepends=('python-krb5: for Kerberos authentication on Linux'
+ 'python-requests-credssp: for CredSSP authentication')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('e4d13c84a5a150c75ec5bc8653059fa78e8421172049e0496d1df89ca24d9a6d')
+sha256sums=('f5500acd11dfe742d51b7fbb61321ba721038a300d67763dc52babe709db65e7')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
package() {
cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}