summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..257bdce8337b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=python-pyqis
+pkgname=${_pkgname}-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Python QIS client for German university information servers"
+arch=(any)
+url="https://gitlab.com/Scrumplex/pyqis"
+license=("GPL3")
+depends=("python-requests" "python-beautifulsoup4" "python-lxml")
+makedepends=("git" "python-setuptools")
+source=("${_pkgname}::git+https://gitlab.com/Scrumplex/pyqis.git#tag=${pkgver}")
+sha512sums=(SKIP)
+
+build() {
+ cd "$_pkgname"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}