summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be259dec38a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dan Trickey
+# Contributor: Dan Trickey
+# This file is automatically generated by Arch Nemesis
+pkgname=python-pyquaternion
+pkgver=0.9.5
+pkgrel=1
+pkgdesc='A fully featured, pythonic library for representing and using quaternions'
+arch=('any')
+url="https://github.com/"
+license=('MIT')
+depends=('python' 'python-numpy')
+makedepends=('python-setuptools')
+source=("https://api.github.com/repos/KieranWynn/pyquaternion/tarball/v0.9.5")
+sha512sums=('272fb4290cb99a8ffa733f5a45bcde97716523cde30a438b5248f38bc6d59c582ea17af73f8af235aec7be8dafcb4ea2e416de07b8263bd9fbf40c0f1595fe8b')
+
+package() {
+ cd $(ls ${srcdir} | grep pyquaternion)
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file