summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45ec6080284b..58624c5bddcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Mantainer: MCMic <come@chilliet.eu>
+# Maintainer: morguldir <morguldir@protonmail.com>
+# Contributor: MCMic <come@chilliet.eu>
pkgname=python-pyscroll
-pkgver=cfe684f
+pkgver=2.19.2
pkgrel=1
pkgdesc="some basic modules to make scrolling pygame games"
arch=('any')
url="https://github.com/bitcraft/pyscroll"
-license=('LGPL v3')
-depends=('python')
-makedepends=('git')
-source=("git://github.com/bitcraft/pyscroll.git")
+license=(LGPL3)
+depends=(python-pygame)
+makedepends=(git python-setuptools)
+source=("git://github.com/bitcraft/pyscroll.git#commit=b41c1016dfefd0e2d83a14a2ce40d7ad298c5b0f")
md5sums=(SKIP)
_gitname='pyscroll'
-pkgver() {
- cd ${_gitname}
- git describe --always | sed 's|-|.|g'
-}
-
package() {
cd ${srcdir}/${_gitname}
python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1