summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92ad0507b437
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Robert Falkenberg <robert.falkenberg@tu-dortmund.de>
+
+pkgname=python-pysim-git
+_pyname=pysim
+pkgver=1.0.r125.g9d16fbc
+pkgrel=1
+pkgdesc='A python tool to program SIMs / USIMs / ISIMs'
+arch=('any')
+url='http://osmocom.org/projects/pysim/wiki'
+license=('GPL2')
+depends=('python'
+ 'python-pyscard'
+ 'python-pyserial'
+ 'python-pytlv'
+ 'python-cmd2'
+ 'python-jsonpath-ng'
+ 'python-construct')
+makedepends=('python-setuptools' 'git')
+source=('git+https://git.osmocom.org/pysim')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pyname}
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^\(v\)\1*//'
+}
+
+package() {
+ cd "${srcdir}/${_pyname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}