summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a9718e72834..40e5255c4208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
_base=pytaglib
pkgname=python-${_base}
-pkgver=2.1.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Python audio tagging library"
arch=(x86_64)
url="https://github.com/supermihi/${_base}"
-license=(GPL3)
+license=(GPL-3.0-or-later)
depends=(python taglib)
makedepends=(python-build python-installer python-setuptools cython python-wheel)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('50c7fa4e5f56f1a6ce18594239335bf281467f708c56579523e5826a39a647a3654d703f18c745c4703a653cbccb9cc8cbfaf7f3c02ea704d74c3d1616a2cdb9')
+sha512sums=('ade4192fd1cc8331d722ccd30852275577bfd9fc3a638de9e6be8723dbfaa6246704ad8c284d52e2138912903a71641f122b777ff646cb9d0571e7596d601426')
build() {
cd ${_base}-${pkgver}
@@ -30,10 +30,5 @@ check() {
package() {
cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
-
- # Symlink license file
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}