summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4857ae4e0151..a6ad4febe2a8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
pkgname=python-pytelegrambotapi
_pkgname=pyTelegramBotAPI
-pkgver=4.15.2
+pkgver=4.16.0
pkgrel=1
pkgdesc="Python Telegram bot api"
arch=('any')
url="https://github.com/eternnoir/pyTelegramBotAPI"
license=("GPLv2")
-depends=('python' 'python-requests' 'python-pytest' 'python-wheel' 'python-aiohttp')
+depends=('python' 'python-requests' 'python-pytest' 'python-wheel' 'python-aiohttp' 'python-pip' 'python-build' 'sed' 'coreutils')
source=("https://github.com/eternnoir/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('5af397c6dc3de672b6b5b549557eeaf5c58c15bf27181357112917808a4ab237')
+sha256sums=('00f13823a48b28241d9e388dcdcff243fa4091fa3363a142b47c0d3c9878641d')
package() {
cd ${srcdir}/${_pkgname}-${pkgver}/
- python setup.py install --root ${pkgdir}
+ py_pkg_path=$(python -c 'import sys; [print(p) for p in sys.path]' | sed -n '/^\/usr.*site-packages/p' | head -1)
+ python -m build
+ mkdir -p ${pkgdir}/${py_pkg_path}
+ python -m pip install --no-deps \
+ --target=${pkgdir}/${py_pkg_path} \
+ dist/pytelegrambotapi-${pkgver}-py3-none-any.whl
}