summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a22451e324b..d2cd515a0791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.6.1
+_name=${pkgname#python-}
+pkgver=4.6.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="https://pyteomics.readthedocs.io"
license=('Apache')
-depends=('python' 'python-pip')
+depends=('python')
+makedepends=(python-build python-installer python-wheel)
optdepends=('python-matplotlib: for pylab_aux module'
'python-sqlalchemy: for mass.unimod module'
'python-pandas: for convenient filtering of CSV tables from search engines'
@@ -15,12 +17,18 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-dill: needed for multiprocessing when pickle is not enough'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
-source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('349aeff0a3be8e276866ce1aa5325a976a159af770d794d1a8b5b94a50f937e7')
+source=("https://pypi.debian.net/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('8c0608b7fbcfc65409e455c4bc8edb91aa9beed65744f37eacac9119ca7335d5')
changelog=CHANGELOG
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- pip install --ignore-installed --root "$pkgdir" "pyteomics-${pkgver}-py2.py3-none-any.whl"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: