summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c4889036579..59c97488e3a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy
_pyname=${pkgname#python-}
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="Metapackage for all the testing machinery used by the Astropy Project"
arch=('any')
@@ -9,19 +9,19 @@ url="https://github.com/astropy/pytest-astropy"
license=('BSD')
depends=('python>=3.7'
'python-pytest>=4.6'
- 'python-pytest-doctestplus>=0.11.0'
- 'python-pytest-remotedata>=0.3.1'
- 'python-pytest-openfiles>=0.3.1'
- 'python-pytest-arraydiff>=0.1'
- 'python-pytest-astropy-header>=0.1.2'
- 'python-pytest-filter-subpackage>=0.1'
+ 'python-pytest-doctestplus>=1.0.0'
+ 'python-pytest-remotedata>=0.4.1'
+ 'python-pytest-arraydiff>=0.5'
+ 'python-pytest-astropy-header>=0.2.2'
+ 'python-pytest-filter-subpackage>=0.1.2'
'python-pytest-cov>=2.3.1'
'python-pytest-mock>=2.0'
'python-attrs>=19.2.0'
'python-hypothesis>=5.1')
makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
+checkdepends=('python-nose')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('23eafccddbeffaef5c0701e42f8fb048')
+md5sums=('51cfee1d56dbe731f1d65b752d2d567f')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -29,6 +29,12 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ nosetests #-v -x
+}
+
package() {
cd ${srcdir}/${_pyname}-${pkgver}