summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 424cb2d61194..9d5b2a06c3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,28 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-openfiles
_pyname=${pkgname#python-}
-pkgver=0.3.2
+pkgver=0.5.0
pkgrel=1
pkgdesc="Pytest plugin for detecting file handles that were inadvertently left open at the end of unit tests"
arch=('i686' 'x86_64')
url="https://github.com/astropy/pytest-openfiles"
license=('BSD')
-depends=('python-pytest>=2.8.0' 'python-psutil' 'python-six')
-makedepends=('python-setuptools')
+depends=('python-pytest>=4.6.0' 'python-psutil')
+makedepends=('python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('b219c5487f7630c3944973cf24709340')
+md5sums=('a3704c256f9343a37095328a5e552d22')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ pytest
+}
package() {
cd ${srcdir}/${_pyname}-${pkgver}