summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85f5b15e0f40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_pkgname='pyTooling'
+pkgname=python-${_pkgname,,}
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="A powerful collection of arbitrary useful classes, decorators, meta-classes and exceptions"
+arch=(any)
+url="https://github.com/pyTooling/$_pkgname"
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools' 'python-pytooling-packaging')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('ed3cced832476f4e2bfa6b597ac4fde1fd0bf36a611676dd9a23f370a51497ab')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+check(){
+ cd "$_pkgname-$pkgver"
+ pytest tests/
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}