summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05f1c7cdbe28..83d3f6f64ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=python-pytorch-rocm
_pkgname="pytorch"
-pkgver=1.10.0
-_pkgver=1.10.0
+pkgver=1.10.2
+_pkgver=1.10.2
pkgrel=1
_pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
pkgdesc="${_pkgdesc}"
@@ -247,8 +247,10 @@ build() {
python setup.py build --cmake-only
sed -E -i 's#opt/rocm/hip/lib/libamdhip64\.so\.[0-9.]+-#opt/rocm/hip/lib/libamdhip64.so#' build/build.ninja
- # same horrible hack as above
- python setup.py build
+ # this horrible hack is necessary because the current release
+ # ships inconsistent CMake which tries to build objects before
+ # thier dependencies, build twice when dependencies are available
+ python setup.py build || python setup.py build
}
_package() {