summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0b5ed128c12..83b1114a3d7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,24 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: awh
pkgname=python-pytweening
+_name=PyTweening
pkgver=1.0.3
pkgrel=1
pkgdesc="A set of tweening / easing functions implemented in Python."
-arch=("any")
+arch=('any')
url="https://github.com/asweigart/pytweening"
-license=("BSD")
-makedepends=("python-setuptools")
-source=(https://pypi.python.org/packages/source/P/PyTweening/PyTweening-${pkgver}.zip)
-md5sums=('41176abe770e8c318dc1f4213831e6da')
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.zip")
+sha256sums=('4b608a570f4dccf2201e898f643c2a12372eb1d71a3dbc7e778771b603ca248b')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
package() {
- cd "$srcdir/PyTweening-${pkgver}"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}