summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0396038cbe58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: jerry73204 <jerry73204 at google gmail>
+
+pkgname='python-pyviz_comms'
+pkgver=0.7.2
+pkgrel=1
+pkgdesc='Bidirectional communication for the PyViz ecosystem'
+arch=('any')
+url='https://github.com/pyviz/pyviz_comms'
+license=('BSD')
+makedepends=('python-setuptools' 'python-param')
+groups=('bokeh-ecosystem')
+depends=('python-bokeh'
+ 'python-cartopy'
+ 'python-holoviews'
+ 'python-numpy')
+checkdepends=(
+ 'python-nose'
+ 'flake8')
+source=("https://github.com/pyviz/pyviz_comms/archive/v${pkgver}.tar.gz")
+sha256sums=('24978f18895c1655364083a464d7327d6cc848ad67ffca40237bfaaa3d8de5c8')
+
+build() {
+ cd "${srcdir}/pyviz_comms-${pkgver}"
+ python setup.py build
+}
+
+package_python-pyviz_comms() {
+ cd "${srcdir}/pyviz_comms-$pkgver"
+ python setup.py install --skip-build --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+}